This vulnerability in Apache Hive... CVE-2018-1282 CNNVD-201804-274

7.5 AV AC AU C I A
发布: 2017-12-07
修订: 2020-06-01

Apache Hive是美国阿帕奇(Apache)软件基金会的一套基于Hadoop(分布式系统基础架构)的数据仓库软件。该软件提供了一个数据集成方法和一种高级的查询语言,以支持在Hadoop上进行大规模数据分析。JDBC driver是其中的一个数据库连接驱动程序。 Apache Hive JDBC驱动程序0.7.1版本至2.3.2版本中存在SQL注入漏洞,该漏洞源于程序使用SQL查询语句之前,没有充分过滤用户提交的数据。远程攻击者可借助特制的参数利用该漏洞控制应用程序,访问或修改数据或利用底层数据库中潜在的漏洞。

0%
当前有1条漏洞利用/PoC
当前有13条受影响产品信息